I-Mockery Forum

I-Mockery Forum (http://i-mockery.com/forum/index.php)
-   Questions, Suggestions, and Tech Support (http://i-mockery.com/forum/forumdisplay.php?f=8)
-   -   Spambots (http://i-mockery.com/forum/showthread.php?t=69701226)

Mockery Sep 30th, 2011 04:57 PM

Alrighty, I had a few minutes to spare this afternoon, so I just installed that plugin that prevents users from posting links until they have 10 posts. Please register a test account or two and let me know if it's working.
:picklehat

Pentegarn Sep 30th, 2011 05:03 PM

Doesn't seem to be. There's a test fake spammer spamming it up in chat

Esuohlim Sep 30th, 2011 05:05 PM

Yeah, that was me. I hope this isn't too good to be true. :(

Mockery Sep 30th, 2011 05:09 PM

Quote:

Originally Posted by Esuohlim
Nope, it didn't work. I was able to post links as "fakespammertest" :(

When I try to set the permissions "For Individual Forums | For All Existing Forums" I get thrown to the Smilies FAQ page.

Someone in the mod installation thread mentioned "You need to turn on the mod before you try, and be sure you are superadmin when you do. Once you turn it on it will allow you to set all rather than take you to the smilies page. When it's turned off it takes you to smilies."

But as far as I can tell, I have the mod turned on. :/

Mockery Sep 30th, 2011 05:19 PM

Ok try again with another new account and make a new post in General Blabber and let me know if it works.

It should let you post, but shouldn't let any links appear.

Pentegarn Sep 30th, 2011 05:22 PM

:crossesfingers

Mockery Sep 30th, 2011 05:27 PM

Somebody test it : O

Esuohlim Sep 30th, 2011 05:34 PM

Testing worked. No newly registered poster should be able to post links until they make 5 posts without them.

Hopefully this works the way it's supposed to, unless we suddenly get a wave of non-spamming spambots.

Pentegarn Sep 30th, 2011 05:40 PM

Quote:

Originally Posted by the_rapist (Post 744849)
IT WORKS GUYS

Pram character :lol

the_rapist Sep 30th, 2011 05:41 PM

hey it even doesn't let you have a signature with links in it doesnt it

neat

edit: correction, it doesn't let you have a signature AT ALL

Esuohlim Sep 30th, 2011 05:51 PM

Oh right, I forgot about the sig spammers.

I'm counting chickens while they're all hell of still in eggs like a motherfucker, but this is the greatest thing ever

the_rapist Sep 30th, 2011 05:55 PM

is the minimum posts # adjustable

i'd feel safer with 10 or more tbh

Mockery Sep 30th, 2011 06:00 PM

Glad to hear it works! Let's leave the minimum number of posts at 5 right now. If it becomes a problem, I'll increase it to 10 posts later on.

Also, thanks for tracking down this mod, Esuohlim. I'm sure it'll make the lives of the other mods & admins a lot easier too. Good find :picklehat

the_rapist Sep 30th, 2011 07:00 PM

oh wow also you can't READ links/images in sigs until you've got 10 posts

executioneer Sep 30th, 2011 07:31 PM

hmm or not.

further tests required

executioneer Sep 30th, 2011 07:32 PM

okay the sig's showing up despite only having 4 posts but it crossed 5 posts before i deleted one so i don't know for sure if it allows sig links or not

i know sigs weren't VISIBLE when i was logged in though

executioneer Sep 30th, 2011 07:36 PM

yeah, when logged in as the_rapist i can't even see signatures, but when logged out i see everything except sig links and images which are replaced with "YOU MUST HAVE 10 POSTS TO VIEW IMAGES OR LINKS, YOU HAVE 0" so that's weird

executioneer Sep 30th, 2011 07:40 PM

on the plus side though not allowed to PM anyone but mods until postcount minimums are reached, so at least pm spam will be blocked

Esuohlim Sep 30th, 2011 10:04 PM

I just deleted spam without links, but urls were still there >:

Mockery Sep 30th, 2011 11:16 PM

Ok, I'm not sure what the problem is. Can somebody summarize what's wrong when you're logged in as a new user and what's wrong when you're not logged in at all?

executioneer Sep 30th, 2011 11:25 PM

i'm not sure it's something WRONG, per se. I created a new account and could not see anybody's signature until I got past 5 posts, and when I was logged out it gave me a message in place of each link in a signature that I was not allowed to view said link until I had 10 posts.

Mockery Sep 30th, 2011 11:31 PM

Ok try both logged in with a new account and logged out now and lemme know if it's any better. The documentation with this plugin is pretty shitty, so it's a lot of trial & error.

executioneer Sep 30th, 2011 11:34 PM

VISUAL DEPICTION

executioneer Sep 30th, 2011 11:35 PM

whoops, didn't see your post while i was making picture. I'll test again

executioneer Sep 30th, 2011 11:38 PM

yeah the <5 posts account still can't see signatures at all, but logged out people can


All times are GMT -4. The time now is 12:49 PM.

Powered by: vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.